Broken Belt Retainer

I tried to tighten the y-axis belt a few weeks ago, then found out in my first test print after maintenance that something wasn’t quite right, because it failed before the first layer was finished, and slammed back into the y-axis stop.

I was busy for a bit, then finally got around to trying to fix it today, and maybe complete some other maintenance on my printer that I’ve been needing to do for a while, but had never done.  I found out that one of the screws wouldn’t tighten on the belt retainer, and thought I had somehow stripped the screw/hole.  It was at a weird angle and I was tired of bending so much to get to it, so I took the whole assembly off the printer and started looking at it. Just so I had a better idea of what was going on, I tried to back out the other screw on that retainer so i could maybe look at it from the other side, and then I saw that the retainer rotated in a way I hadn’t expected.  I flipped it back over, and saw what you see in the picture above.  That’s a different problem than I had expected.

I’ve contacted CoLiDo, and I’m hoping they can ship me a replacement part and instructions on how to install it.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s